Roboguide diagnostic pro

  • Hello,


    I am trying to connect Roboguide diagnostic to an RJ-30ib controller unsuccessfully. Where I am uncertain does it matter what IP address i setup on both my laptop and robot?


    Where do I configure my ip address on the robot? Under host comms i setup my ip as 192.168.1.1 and my laptop set to 192.168.1.2. I cannot ping the controller.


    please if someone has connected diagnostic pro to their laptop through roboguide, would you be kind enough o help me out.


    Thank you.

  • probably have it in the wrong port. the standard R30iA has 3 RJ45 connectors on the main board. CD38C is at the bottom and is normally only used for vision systems. at the top you will find CD38A (port 1) and CD38B (port 2). each port has to be set up in the host com screen, you can change the port by using the F key labeled PORT. each one has to be on a unique subnet mask. they are isolated and traffic does not cross them. in order for any changes to take place the controller has to be restarted.

  • Thanks, I have a crossover cable plugged into the top port with the IP configured for that port. I am now able to ping the address and access the fanuc web page via my browser successfully. However when try to connect through diagnostics pro it wont connect, it only says ''connecting'' under the robot monitor screen.

  • I am having the same issue. I know you need to have Diagnostic Interface (Option R-711) installed but it will not even connect to the point of verifying if the option is or is not installed. Any help would be great.
    Thanks in advance.

Advertising from our partners