problem in RX130 with CS7 controller

  • hi everyone
    many tanks for taking time in advance.
    we are working with RX130 - CS7(1995) for first time. the following errors have been appeared on the screen. hence the robot do not run in Jog mode:
    *NVRAM battery failure *
    *Protection error*
    s130_STD.SPC . D34114711A.25/10/95 .75/32 . Speed control
    *Option not installed*
    *Robot module not loaded* ID:14
    that would be kind of you if you let me know,how could i solve the above problems?
    as you know , the mentioned robot type is very old. so finding the spare parts could be more awful :wallbash:
    look forward for your prompt reply.

  • Place your Ad here!
  • Keep An Old Real Time Clock Module Ticking
    Sometimes we run into real problems restoring old machines. [RedruM69] recently ran into a system with a dead Real Time Clock (RTC) module. These modules were…

    You NEED to back up your entire HDD asap! On a floppy, and on your pc. These hdds fail eventually.

    This link will get your nvram chip functional again ( you need to be realll handy with a dremel and a soldering iron - otherwise purchase one from Cotsco on ebay?

    A removable battery tray would be ideal.

    Do not bother with any other replacement chip. Believe me, I've tried quite a few. YOU NEED an original. They really really do not make these any more.

    Once that is sorted you need your robot's spec file - which might be backed up on your hdd if you are lucky. If you haven't backed up your system it is a really good idea. You can remove the hdd, use an ide or scsi adapter, hook the drive up to your computer. Use a program like HDDGURU to make a binary copy of your drive to either a virtual disk on your computer, or better yet an ssd with a slightly larger capacity than your original drive. (Most any size should work).

    If you do make a copy to your computer, drop the binary file into a virtual disk and then use hdd guru to copy that virtual disk to your ssd, ect. That way you'll have it backed up twice. Ideal would be if you can manage to find a similar and model ide drive - if you back it up to that there's a good chance you'll simply be able to swap drives quickly when the original fails.

    If you have the scsi drive they are really hard to find replacements for. Peel off the adept sticker and you'll see an Apple Quantum drive sticker. I had good luck using a mac laptop hdd emulator to replace my quantum drive. (intertial You install the drive, boot from a floppy boot disk, and either just format the drive "format c:\" or maybe I had to use config_c to format it. Can't remember. The important thing is to have the Adept controller format the drive for you. I can verify it worked on my cs7 rx90.

    Once your nvram and hdd are sorted out, get in touch and there may be a way I can fix your license problem (the nvram wants a password or several).

    If I don't have the key you need, perhaps I know someone else who does.

    I also realize this is an ancient post - but there will be another person who this may be helpful to, so that's why I'm responding now :winking_face:



  • Howdy, I have a rx130 with cs7. I did some Dremel work on my NVRAM chip and got it powered up. I'm able to go further along in the boot process however I'm getting a "robot interlocked" error as well as a "robot not connected to system" error. Any ideas?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners