Nachi MZ07 Functions + Vision Guided App

  • I have a nachi mz07 that I am trying to create a vision guided pick and place application using a Cognex camera. I am having difficulty getting communications going between the robot and the camera. When I hit the help button on the teach pendant and go to the function list I see there are functions for opening a socket, closing one, etc. (Functions FN570-FN577). When I go back to my program and hit the FN key these functions are not listed in the list. Is there something I'm missing? Does anyone have any other suggestions for communicating with the camera via a client/server relationship?
    Thanks!

  • AD
  • Right, meaning socket functions are only usable in Usertask programs.


    A bit off topic, but at least in AX (I don't remember which controller exactly) for some reason one can't use local variables with Socket functions, so don't wonder with weird error messages. Not comment what so ever about this in the manual (nor about the fact that UserProc's take only three parameters max and the UserProc declaring line can't be longer than 100 bytes, too me way too long to figure this out too.)


    I'm not exactly sure if one can use DIM allocated variables with sockets. This language is a bit messy compared to some others I've worked with.

    Eero from Finland

  • Socket Function has to be created in Robot Language and then complied eg To create a socket SOCKCREATE 1,0 etc
    Socket function eg FN570 cannot be used directly from Teach

    Hi I am having a similar issue, i found your solution and am still having no luck, I get an error, E18 A command was not recognised. I have tried many different syntaxs also

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now