ABB IRB 2000-2480 S3 M93 problem Error 536

  • Hello!


    I am new to robotics and I have some problem getting started with my IRB 2000-2480.
    The drive unit is an M93 control system S3.


    When I try to start the robot - and push motors on, I get the following error message 536 34 and 21.
    According to the error list documentation 536 34 means that: An attempt has been made to start up with un-defined commutating offset.
    Remedy is: Define the commutating offset.
    I don't know how to do that, or even what it means.
    Could anyone explain in simple terms how I should proceed.


    The error 536 21 means that:
    A break in the enable loop.
    Several alternatives can be the cause:
    A a driver unit has been tripped because of over current.
    B The supply unit or rectifier has tipped.
    C Fault in the server computer.


    I don't know which of these it could be, and even if a remedy is offered for each one of them, I don't know what to do.


    I would be greatful for any help and suggestions.


    Best regards
    Carl

  • AD
  • Hi,
    Welcome to our world! Fell free to share experiencies in this place!


    First you need to solve the fault 536 34 and then we'll see if the 536 21 goes out.


    To execute commutation procedure follow the path:
    1 - MAN (The key which seems like a hand or finger on Teach Pendant)
    2 - PARAM
    3 - RESOLVE
    4 - COMOFF
    5 - AXIS NO = 1~6
    6 - ENTER
    7 - UPDATE


    The main idea is that, when you have IRB2000 the commutation offset depends on the each motor. These values should be in the label on the robot so you can introduce it through the path above. If not is necessary to align each axis in the commutation position. There is a mark in the brake plate and other mark on the fixed part of the motor, both marks must be align to execute the commutation reading. The second way is harder because the axis 1 is under the robot, the upper motors are in the bad position and so on.


    Fisrt you need do this, let's go see the result!

  • Thank you for the excellent instructions!
    I will try to follow them, and then report back.


    Best regards
    Carl

  • Bonjour,

    nous avons un robot IRB2000 S3 et je n'arrive pas à le synchoniser il se met en défaut 506 ERREUR SERVO2 1406 et quelques fois il se met en défaut 536 safety hazard,quand j'effectue un auto test toute les led passent en verts.

    merci pour vôtre aide.

    cordialement.

  • Because you mention syncing the robot, I assume this is the older S3 style between M88 & M90A.

    The 506 Servo Error 1406 occurs when axis 6 is commanded to move but the axis 6 resolver values do not change.

    Can you manually move axis 6 if you press the axis 6 motor brake release button?

    If you can manually move axis 6, go to the SYNCOFF parameter menu and keep press NEXT until you get to A6 FINE to see the resolver value. The value should be steady or only changing between 2 adjacent numbers. Press NEXT and verify the same for the A6 Coarse resolver. While at the A6 Coarse resolver menu, release axis 6 brake and verify the resolver values change when the A6 axis moves. Cycle power on the controller so any accidental changes are not saved (written to the EEPROM), DO NOT press 'ACTIVE'.

  • bonjour,

    merci pour vôtre réponse , oui c'est un IRB2000 S3.

    comme il se met en défaut nous ne pouvons pas déplacer manuellement en appuyant sur le bouton désserage du frein moteur,on perd le 24v.

    pourtant nous n'avons aucun défaut sur les cartes DSQC210 et DSQC211.

    Nous avons aussi inversé les cartes YTE102A.

    Cordialement

  • Bonjour,

    nous avons le 24 v sur les contacts du contacteur RUN mais pas sur les boutons poussoires pour desserer les freins sur les axes 1,2,3,4,5 et 6.

  • I think there is a 24V brake fuse on the power unit. Did you identify a Brake fuse?

    I remember the 24V Brake voltage was usually closer to 23V, but 22V should still work.

    Did you download the S3 Service Manual found >here< ?

    Page 206: Typical S3/S4 Brake PB connection > X1:B16 (24V) & X1:B15 (0V)

    If no voltage, check Page 204: Brake PB (push button) 24V on connection X2:35 & X2:28

    If there is Brake PB voltage at X1:B16 (24V) & X1:B15 (0V) then check the MP cable and connection at the robot.

  • j'ai téléchargé le M90 IRB2000 mais je ne vois pas sur la pag 206 le X1:B16 et X1:B15 aussi sur la page 204 je ne vois pas le X2:35 et X2:28.

    Est ce le fusible de frein 24vDC se trouve bien sur le bloc d'alimentation de puissance?si oui ce fusible est bon.

    Merci pour vôtre aide.

  • Nous allons examiner le câble MP et la connexion au niveau du robot car nous avons le 24v.

    je mesure 60v au lieu de 220v à la page 48 sur les bornes X1:12 et X1:13 pourtant le fusibles 4 et 5 sont bons?

  • le processeur est un DCQC202, je vais voir pour le numéro de série.

    Les cartes sont dans cet ordre :

    YTE 102 B ,YTE102C, YTE102B, YTE102A, YTE102A, YTE102A, DSQC209, DSDXB001, DSRB110, DSDXB001, DSQC210, DSQC211,DSQC202

  • Bonsoir,

    Merci beaucoup pour vôtre aide nous avons réussi à synchoniser le robot.

    Pour cela nous avons changé un relais RUN car le contact NF était bloqué et nous avons réparer la piste de la carte éléctronique ou se trouvent le boutons pousoires pour déssérer les freins des 6 axes.

    Cordialement.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now