Communication with DX100

  • Hi,everybody
    im using PC(Vision system) to communicate with DX100 and not experienced on this (without motocom32) :help:
    1.DX100 is a master in DCI Function,could i turn it around? :wallbash:
    2.Does RS232 transmission format work on Ethernet?
    3.Could Host Control Function work on variable set using LOADV/SAVEV?
    some example code for me is pleasure,VB6.0 is better
    my e-mail:[email protected]

  • Hi there,

    I am also trying to communicate with the host function since this week but haven't got any luck. I'd also like to know if someone who know how to communicate with it. I've set all parameters and remote is also showing "I/O and Command Mode" in TP. I'm using DX100 controller.

    Command sent (sent one by one, with and without "<BSC command>" pad character):

    Response received (in decimal :(
    016 048 005 016 048 005 016 048 005 005 005 005 005 005 005 005 005 005 005 004 016 048 005 005 016 048 005 016 048 005 005 016 048 005 005 016 048 005 005 016 048 005

    All examples in data communication manual says that I must receive ACK1 (016 049) after BCC but I don't. What is the correct way of doing this?

    Edited once, last by motorobo ().

  • hi travor,

    yes, i also figured out is working now in at least DCI mode (robot controller as master) and i know what mistake i did :grmpf:
    must be possible with host mode but dci must be enough for me. Now i'm writing a c or c++ application for it.

    hope you're doing well too! :beerchug:

    Edited once, last by motorobo ().

  • Hi motorobo
    It's a long time before I return to this case. I just read my program and the bug is out.
    It works well and thank for your warmhearted reply. :beerchug:

  • Hi everybody,
    This is my very first post and I can see that I share the same problems that so many people! :uglyhammer2:

    I'm trying to integrate a Cognex IS7200 camera to a Motoman robot, DX100 controlled. The task is to read a couple of coordinates and correct the position.
    I've been seccesful using RS232 serial communication (SAVEV and LOADV commands). But response is sooooooooo slow that I must turn
    into Ethernet as soon as possible.
    The fact is that I don't know if these DCI commands aply the same to Ethernet communication.
    Using Telnet over PC is so easy and simple. Just sending camera IP address, then sending user and password, then sending a simple ASCII string to trigger and then a simple ASCII string
    to get the coordinates in a couple of lines.
    But, how to do this on Motoman DX100 programming enviroment?
    I just get the 4102 alarm with subcode (90).
    Please somebody send me a clue!!!
    Many thanks to all you guys!

    Franco :top:

  • I believe when you setup the Cognex inside Insight Explorer, you can pick Motoman for communication mode. This only works over the RS-232 port of the Cognex.

    On the Motoman side, DCI will function in serial and Ethernet port.

    You might want to look at doing EthernetIP function or investigate MotoSight2D. The MotoSight product is an ethernet interface designed for Cognex.


  • Hi fbolzoni
    How fast could you need for your transmission speed? I have tested the speed of RS232 transmission in VB6 code and it costs about 300ms.
    The next step for me is to try the Ethernet. All I know about the Ethernet transmission from the service of Robot is that it has the same transmission
    format with RS232.
    Your error code 4102 alarm with subcode (90) seems like the error code I experienced "4104" which means wrong order by "LOADV".Yours means you have sent the wrong order to DX100 by "SAVEV".Just check your code!
    I will try Ethernet transmission and we could communicate if any question occurs.

  • RoboGuru,

    Ethernet control of the camera is been done, using Telnet. So I guess that sending same instructions over DX100 should be that simple too. But I have no documentation were to get support of
    the Ethernet programming using DX100.
    What do you mean with 'doing EthernetIP function'?
    I know that Motosight solves the problem but it requires time that I do not count with.
    Many thanks!

  • Hi Travor,
    The camera resolves it's own recognition program in a couple of tenths of a second. But Motoman takes a couple or more of seconds to trigger, retrieve and apply changes to position variables. It's inacceptable for our
    pourposes. About VB6 code I have no experience at all, do you have any sample job?
    Regarding the syntax of programming lines for Ethernet function at least it share the commands with RS232, I've checked that because the errors/alarms refer to that function, meaning that Ehernet is being disturbed and he wants nothing with me!!! hahaha.
    The problem is that 'communication steps' between native commands on Cognex processor and DX100-Rs232 are a solved issue, shown on many documents. But what I want is to 'emulate' the 'communication steps' that is possible with Telnet:
    user: admin
    password: admin
    sw8 // here the camera is triggered and the program determinates the coordinates that the robot needs.
    gv007 // here the camera is asked for the coordinates obtained in the previous command
    234.587 //these are the coordinates, that simple.

    But how to link this protocol with DX100 variable enviroment? That is the question,
    So far I have received error alarms only..

    Many thanks everybody! :icon_smile:

  • I am trying to communicate with DX100 via LAN as mentioned in the High Speed Ethernet Server Function Manual.

    I am trying to get the position data with the Robot Position Data Reading Command as per the Manual. The data sent is as follows (This in decimal form): [89, 69, 82, 67, 32, 0, 0, 0, 51, 49, 0, 0, 0, 0, 0, 0, 57, 57, 57, 57, 57, 57, 57, 57, 117, 0, 101, 0, 6, 14, 0, 0]

    This is as per the packet format mentioned in the manual. The above data when converted to ASCII & hexadecimal reads as Y,E,R,C,0x20,0,0,0,'3','1',0,0,0,0,0,0,'9','9','9','9','9','9','9','9',0x75,0,101,0,6,0x0E,0,0.

    I am getting a error in the reply which is Format Error (Access level error) as per the Manual. I am unable to find the error in the format. Please help.

  • This is the command I'm sending and it works for me (in HEX)
    I have never got the error you're getting, so I'm not sure what it means... try sending the above pocket and see if you get the same error

  • I am trying to get the position data with the Robot Position Data Reading Command as per the Manual. The data sent is as follows (This in decimal form): [89, 69, 82, 67, 32, 0, 0, 0, 51, 49, 0, 0, 0, 0, 0, 0, 57, 57, 57, 57, 57, 57, 57, 57, 117, 0, 101, 0, 6, 14, 0, 0]

    While making some tests I came across the same error you've got (E4A4). change your 9th and 10th elements to HEX:
    instead 0x51 (ascii convertion to '3') use 0x03.
    instead 0x49 (ascii convertion to '1') use 0x01.
    that will solve your problem...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now