$remote variable stuck at 0 (RJ2)

  • Hello... :icon_smile:


    I have ARCMAte 120iL with RJ2. ARCTOOL software
    When I test my LOCAL REMOTE key I see in SOP SI[2] that it is changing form 0 to 1 but when I check system variable $remote, it is always 0? No change.
    It looks like key is working but robot is not using SOP signals correctly?


    Is this OK or something is wrong with robot, because I have a problem with cycle start(not working with SOP or UOP:( ).


    thanks, :help:


    regards

  • Place your Ad here!
  • My next question was going to be regarding UO[0] CMDENBL :icon_smile:
    CMDENB is OFF and I don't know why.
    UI IMSTP , HOLD, SFSPD and ENBL=ON and I'm trying to Cycle start with UI[6] or UI[30]PROD start, but I get syst_008 "Nothing is the Master Device" alarm.
    I have tried SOP cycle start(UOP disable) but same result.


    I think that something is wrong with $remote variable. Robot doesn't know if it is in local or remote? maybe .. I don't know :hmmm:
    When I installed handling tool software everything worked fine but with ARCTOOL I can't cycle start.


    Thanks

  • I remember if you change the $rmt_master variable that you have to cycle power.
    Here is the explenation for cmd enable


    Remote condition
    When the robot is in the remote state,the program can be started by using the peripheral I/O.
    Signals(*HOLD,ENBL) which has relation to safety is always effective whether the remote condition is satisfied
    or not.
    When the following remote conditions are satisfied,the robot is in the remote state.
    J The teach pendant enable switch is set off.
    J The remote signal (SI[2]) is on. (For how to turn the remote signal on and off, see the description of
    Remote/Local setup in Section 3.16, “SYSTEM CONFIG MENU.”)
    J The *SFSPD input of the peripheral device I/O is on.
    J The ENBL input of the peripheral device I/O is on.
    J A value of 0 (peripheral device) is set for system variable $RMT_MASTER.
    NOTE $RMT_MASTER Specifies the kind of remote device.
    0 : Peripheral device
    1 : CRT/KB
    2 : Host computer
    3 : No remote device
    A programincluding amotion (group) can be started onlywhen the remote conditions and the following operation
    conditions are satisfied:
    J The ENBL signal of the peripheral I/O is set on.
    J The servo power is on (not in the alarm state).
    The CMDENBL signal indicates whether the above conditions are satisfied. The signal is output when the
    following conditions are satisfied:
    J The remote conditions are satisfied.
    J Not alarm status.
    J The continuous operation mode is selected (the single step mode is disabled).
    NOTE Peripheral I/O signals are disabled in the initial state. To enable these signals, set TRUE at “Enable
    UI signals” on the system configuration screen.

  • Thank you TRBe.. :beerchug:


    But I think I have to go back to start and find correlation between REMOTE LOCAL key SI[2] and $remote variable(0 or 1) and why it is not changing when I'am using key switch.



    Any more ideas? :hmmm:



    Thanks

  • I found the $start_mode variable in roboguide, but I cant find it in any manual so I have no idea what it does.
    Too bad its RJ2 I cant check yours backups in roboguide.
    Try menu, setup, program select to see it, Im not sure this is possible with rj2.
    Can you take a picture of your config screen?

  • Hello...


    I think we found what could be a problem(thanks TRBe :top:).


    1. I have A16B-3200-0040 CPU (NORTH AMERICA) . It is North America style controller with A20B-1006-0290/02B panel board with NO AUTO/T1/t2 switch.
    2. I have ARCTOOL 7D60 software edition V4.30P/B6 that is probably for Europe. (maybe someone could confirm this?) This Europe software require AUTO/t1/t2 switch.


    So this two things are probably not compatible. And this is why I can't (sop)cycle start or put it in remote and UOPstart. Controller is waiting for auto/t1/t2 switch input.


    But what to do now?? :hmmm: Somehow connect AUTO/T1/t2 switch to panel board? Install north America Arctool software?

  • Just wondering if you have tried loading your arc tool software with the other type of kfloppy cable maybee there part of the program that is not loading maybee somepart of software firware has been lost to do with the communication
    Am not shure how this works but there is two diferent cables listed for use just have not understood when you use each one there must be a explination

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners