June 19, 2019, 03:09:03 AM
Robotforum | Industrial Robots Community

 Cognex In-Sight camera Telnet access

normal_post Author Topic:  Cognex In-Sight camera Telnet access  (Read 201 times)

0 Members and 1 Guest are viewing this topic.

May 16, 2019, 08:57:46 PM
Read 201 times
Offline

SkyeFire

Global Moderator
I have a slightly old InSight 5400-C11, with Firmware revision 4.10.5 (the highest one offered for this camera, AIUI) that I use for various test and experimental work.  I recently tried to connect to it using Telnet, instead of using EIP or ProfiNet, and ran into a maze of strange issues.

I did eventually manage to make it work, but I'm still trying to work out the root cause.

I was using two different Telnet clients -- MobaXTerm, and PuTTY.  Whenver I tried to make a Telnet connection to the Cognex with either one, I would see the "Welcome" message from the camera, but the connection would then close instantly, before I hit a single key.

I eventually went through a complete factory reset of the camera, and a firmware update (I had previously been running 4.10.02).  But still had exactly the same problem.

However, then I tried PuTTY in Raw mode, instead of Telnet mode, and was able to log in and control the camera.  I still need to research exactly how these modes are different, but from what I understand, Telnet mode includes some low-level protocol handling that is inherent to the Telnet specification, while Raw mode only opens the port, and starts sending/receiving ASCII strings.  I'll note that Raw mode works more like RS232, just over TCP/IP instead of a serial cable.  And Cognexes were originally built around RS232 communications, before Ethernet took over the world.

I'm still trying to figure out if there's a way to "tweak" the Telnet mode settings to resolve this problem, and what the ramifications of this issue might be when I start writing PC programs to access the Cognex via "Telnet."  Or, maybe this is something specific to my camera or firmware, I'm not sure.

Today at 03:09:03 AM
Reply #1

Advertisement

Guest


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

clip
Cognex In-Sight Camera With Universal Robot URCAP

Started by ambrose on Universal Robots

2 Replies
457 Views
Last post March 21, 2019, 12:06:32 PM
by edouardtende
clip
Kuka communication failure with Cognex In-Sight smart camera over Profinet

Started by YangTao on KUKA Robot Forum

13 Replies
7620 Views
Last post December 13, 2016, 03:09:58 PM
by SkyeFire
question
KUKA communication with Cognex In sight

Started by Robin de Bree on KUKA Robot Forum

16 Replies
2033 Views
Last post June 12, 2018, 12:21:38 PM
by panic mode
xx
Interfacing with a Cognex camera

Started by Racermike123 on Fanuc Robot Forum

6 Replies
774 Views
Last post January 14, 2019, 05:38:34 PM
by RobotWizard0216