February 20, 2019, 07:54:01 PM
Robotforum | Industrial Robots Community

 E0052 Servo error :Battery discharged or encoder abnormal (S Axis) - SA160F-01

Author Topic:  E0052 Servo error :Battery discharged or encoder abnormal (S Axis) - SA160F-01  (Read 2030 times)

0 Members and 1 Guest are viewing this topic.

January 29, 2017, 09:22:04 PM
Read 2030 times
Offline

Dancy


Ok,
Sorry baby, I have been neglecting you standing there in the middle of my shop. I have not turned you on in many months and now that I have, you don't want to talk to me and you won't play nice.

Well that sorta says it. Been really cold down here this winter in the shop. When I first fired her up I had that error on several axis. I replaced all the batteries in my SA160F then used the reset jumper on each of the axis. All seemed to come back normal except the S axis.

I have tried several things. My robot does not have the capacitors with the batteries. I found each encoder/resolver has a super cap internal. I tried leaving the plug to encoder off all night. Tried discharging the super cap. Last thing I did was swap the H and S axis resolver connections and yes, the error moved to the H axis then. I reconnected the cables back to there respective resolvers. So it appears that my problem is in the resolver itself. I Don't have a great deal of information on these resolvers in order to determine if it is bad or just confused. I can tell you when the reset jumper is connected to any of the plugs, I do get the "beep" out of the pendant and a message saying E0051 Servo error :Data transmission error (? axis) where ? is the axis reset. Apparently the S axis resolver is talking to the AR controller. The wiring diagrams I have show ten signal lines:
SIN +
SIN -
COS+
COS-
OUT1+
OUT1- 
OUT2+
OUT2-
OUT3+
OUT3- 

I don't know what I should see if I scope those.

Another clue, I can't get into the encoder correction under Constant Settings. Think it is because of the E0052 preventing "Motors On"

Any help getting my SA160 back up would sure be welcome.
Thank you!

Today at 07:54:01 PM
Reply #1

Advertisement

Guest

March 20, 2017, 06:21:02 PM
Reply #1
Offline

Dancy



February 08, 2018, 08:57:57 AM
Reply #2
Offline

dhysta


hi dancy..
how did you fix the error E0052 ? what was the real problem ?
i'm having a same error on NB04L with EX21 controller..

March 28, 2018, 12:48:41 PM
Reply #3
Offline

r013071c5


Yeah.... please share how u resolve it Dancy... it would be good to share the knowledge.


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Servo (0) Encoder Battery Low Voltage Error Code (0A0W1013)

Started by DakotaTube on Kawasaki Robot Support Forum

1 Replies
1082 Views
Last post September 05, 2017, 05:53:05 PM
by kwakisaki
clip
Alarm 4314 Encoder Battery Error

Started by tp123 on Yaskawa Motoman Robot Forum

2 Replies
2392 Views
Last post July 03, 2016, 02:39:26 AM
by Gilbailey10
xx
ABNORMAL SERVO TRACKING[Error Code: E0021]

Started by AJ on Nachi Robots

3 Replies
1937 Views
Last post March 20, 2017, 10:18:40 PM
by bsrr
question
ABNORMAL SERVO TRACKING[Error Code: E0021]

Started by sonaldhake on Nachi Robots

2 Replies
866 Views
Last post February 06, 2018, 03:57:03 AM
by Roboter