April 24, 2019, 10:44:56 PM
Robotforum | Industrial Robots Community

 S3 IRB2000 with major fault

Author Topic:  S3 IRB2000 with major fault  (Read 892 times)

0 Members and 1 Guest are viewing this topic.

December 29, 2018, 12:48:51 PM
Read 892 times
Offline

mk768780


Hello everyone.

I have an IRB2000 with an old S3 controller and also looking for as much documentation as I can get. I am looking for wiring diagrams and service manuals if possible. I have searched about and most of the links on this forum seem to be quite old and expired.

At the moment every board on the controller has a red error light including the CPU. Not sure where to start?
I am trying to confirm what pins on X3 should be strapped to ensure that the external safety interlocks are disabled at the moment until I get it working.

Another thing I noticed is the NiCad battery pack seems to have leaked and I assume its not working.

Looking for details on what I should be looking for on the various test pins on the VME bus boards, voltage or oscilloscope waveforms?

Any help would be appreciated.

Thanks

Merik

Today at 10:44:56 PM
Reply #1

Advertisement

Guest

December 29, 2018, 04:32:26 PM
Reply #1
Offline

Skooter


IRB2000s were built from 1987-93.  I like to call the M87-M90A "Old S3" and the M91-M93A "New S3".  Because of the major changes between old S3 and new S3, please supply the model year designation (M87-M93A) or the serial number.

Whenever resurrecting old equipment, always verify the power supply as some of the main components in them deteriorate with age.

December 30, 2018, 12:35:26 AM
Reply #2
Offline

mk768780


Thanks so much for your swift response.

I can't find numbers like that, here are some photos of the outside and inside.
Hope you can identify by that means.

« Last Edit: December 30, 2018, 12:21:42 PM by mk768780 »

December 30, 2018, 03:49:17 PM
Reply #3
Offline

Skooter


Since it has a DSQC215 CPU, it's either an M90 or M90A controller with an external axis.  The M90 power units are YB560101-Gx, the M90A are YB560101-Lx.  There was an M90A/2 but I don't remember what changed.

Make sure the 3-position mode switch on the CPU is in the RUN position.
Check the voltages at the test points on the front of the DSQC211 power supply.  I remember the 24V was always high which was normal.

I tried posting a Product Manual for the M90 IRB2000 but the forum gives me an error.  It is a 6.8MB PDF.

Try searching 'M90' in only the ABB section & Manuals ... child board of the forum.  There are other similar posts.

December 30, 2018, 08:50:04 PM
Reply #4
Offline

mk768780


Thanks

Any chance you could send the manual to me via dropbox or email?

January 02, 2019, 08:41:45 PM
Reply #5
Offline

Skooter


Sent you a PM.  Tried again to upload it but still getting error from Forum.  Seems to happen with some of the older ABB manuals.  Newer ones post just fine.  :hmmm:

February 02, 2019, 07:48:06 PM
Reply #6
Offline

zbusz


Hi
I am new on forum. We have bought IRB2000 robot and tried to make it to work. Now robot is not synchronized and get some hazard error code 22. Is it possible you could send me manual for IRB 2000 M90 by email too?

Today at 10:44:56 PM
Reply #7

Advertisement

Guest

February 08, 2019, 12:19:01 AM
Reply #7
Offline

Skooter


Welcome to the forum.  Thanks to some upgrades to the forum recently, I was easily able to upload the manual.
https://www.robot-forum.com/robotforum/manuals-software-and-tools-for-abb-robots/m90-irb2000-product-manual/

Regarding the error code, seen this caused by dirty e-stop switches.  Try cycling all the e-stops many times with the power on to help clean the contacts.


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
fix after a major wreck

Started by hammerhead on Yaskawa Motoman Robot Forum

3 Replies
407 Views
Last post September 12, 2018, 08:43:16 PM
by 95devils
xx
ABB IRB2000 M93 I/O

Started by Simonas on ABB Robot Forum

3 Replies
373 Views
Last post November 23, 2018, 12:24:06 PM
by RoboWeld
xx
Unsupported major.minor version 51.0

Started by WalterPintor on KUKA LBR IIWA

4 Replies
662 Views
Last post May 04, 2018, 08:27:46 AM
by kiiwa
xx
Motoman Major alarm I can't reset

Started by AMCloin on Yaskawa Motoman Robot Forum

7 Replies
12691 Views
Last post September 29, 2014, 09:27:29 AM
by AMCloin