March 25, 2019, 02:17:33 PM
Robotforum | Industrial Robots Community

 Weird mastering position and method, bad TCP accuracy, measurement problems

Author Topic:  Weird mastering position and method, bad TCP accuracy, measurement problems  (Read 567 times)

0 Members and 1 Guest are viewing this topic.

July 20, 2018, 11:18:19 PM
Read 567 times
Offline

Spirit532


I have a KR3 robot(the CRS F3 kind, not Denso) with a KRC3 controller(KRC2 ed05-ish), KSS 5.2, not HA/Position Accurate.

While I was testing the 4-point XYZ TCP measurement, I came across a very odd issue - it kept telling me that my error was really huge, 8-15mm, whereas in reality the alignment was done by using two sharp ground points, and my eyesight is good enough to spot an 8mm gap.

I did manage to make it set up once with less than 5mm of error, but when I tried jogging it in the world reference, the TCP moved several millimeters through the motion range(A/B/C orbits), which was way more than I expected.
After several attempts, I decided to re-master the robot, to see if the accuracy improves. This is where I hit another issue - the manual for my robot states that user mastering is done only via vernier marks(3 slits that line up to a single line or another 3 slits) on the outside of the robot. But the issue I came across when doing this was that for one, the vernier marks didn't work. The robot did proceed with mastering, but on every axis(after completion), it also gave me warning #46 - "Axis too far from mastering position <number>".

Running the routine again, the accuracy did improve, but not by much - I was still seeing a few mm of TCP variance when jogging. I was also still unable to do a TCP measurement with large variance - the more I pushed the axes out, the bigger the error became, so I limited the TCP measurement to +-15-20 degrees on each axis.

Now, the issue with verniers. While my robot only has vernier marks, it did not align properly to the marks on some axes. On some axes they lined up perfectly when mastering, but on others I had to line the slit up with either the left or the rightmost mark, instead of the middle, to ensure warning #46 did not pop up. And another observation - when mastering anywhere near the original, bolted-in verniers, the robot position is way off - so much so, it jumps out at you from a glance. A2 is tilted towards +, A3 is lined up with it, A4 is slightly to the side(left mark instead of center), A5 is also tilted towards +, and A1 is a complete disaster - it's so crooked, the body, whilst aligning to the vernier(left mark, again), is at the very least 5-7 degrees to the side(if looking at the base).
I'm also fairly certain that the verniers were not tampered with, because on A1 they're bolted into a recess, and it would be very difficult to place them elsewhere. The holes on them are slightly elongated for minor adjustments, but they can't go to such an extreme extent.

I thought this was just the mastering offset, but no - when I looked at the axis-specific angular positions, they were all at or very close to 0, so doing PTP {A1 0, A2 0, .... } resulted in the robot being very crooked, and definitely not level.
After this vernier-based mastering, I could manage to get a TCP alignment 2/3 times, but it still resulted in a very visible motion during jogging, not at all coherent with the measurement error.

To add to all this, the repeatability is superb - I am regularly able to hit the 35-60um mark with a specified repeatability of 50um, so I don't think it's wear(not to mention only 7000 hours of light use, first maintenance is due way above 10k).

So the questions are:
1. What is going on? Why am I not able to get at least <1mm deviation from a small(~120mm long) tool on a tiny robot?
2. Is there any reason the verniers might be so way off straight angles, but still in the stock positions?
3. The robot comes with separate factory mastering - is there a way to restore it over user mastering?
4. If I had a very, very precise tool of known dimensions and a rigid external reference, could I calibrate my robot manually? Perhaps via the High Accuracy option, that isn't enabled?

Any insight is appreciated.
« Last Edit: July 20, 2018, 11:20:23 PM by Spirit532 »

Today at 02:17:33 PM
Reply #1

Advertisement

Guest

July 21, 2018, 03:00:10 AM
Reply #1
Offline

panic mode

Global Moderator
1. clearly mastering is incorrect
2. no idea what this means. why do you think that that vernier marks are in wrong positions?
3. try following:
* replace batteries and turn controller on for few hours to charge the batteries
* set factory mastering using counters (contact Kuka for help)
* repeat vernier mastering
« Last Edit: July 21, 2018, 03:09:26 AM by panic mode »
1) http://www.robot-forum.com/robotforum/kuka-robot-forum/read-first/
2) if you want reply about robot, post it in forum
3) read 1 and 2

July 21, 2018, 12:09:12 PM
Reply #2
Offline

Spirit532



When I move the robot to 0,-90,0,0,0,0, it does not stand straight. The axes are visibly misaligned, see these photos:





The issue is - the robot will only master without warnings when in this position, not when perfectly aligned to the verniers.


Done that, both backup and encoder batteries are only a few weeks old, both sets are charged up fully.


I don't think that's possible on my robot - the counters reset when mastered. Are you talking about something other than this?
« Last Edit: July 21, 2018, 12:14:59 PM by Spirit532 »

July 24, 2018, 09:28:42 PM
Reply #3
Offline

Spirit532



July 25, 2018, 11:24:17 AM
Reply #4
Offline

panic mode

Global Moderator
those are quite rare units. i never worked with one... why not do the natural thing and contact KUKA support?


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Best method for mastering after replacing wiring harness...can't all reach zero

Started by Archer on Fanuc Robot Forum

19 Replies
3193 Views
Last post September 24, 2018, 07:52:19 PM
by bagged2drag
xx
KUKA KRC2 Absolute Accuracy Problems

Started by lynskey24 on KUKA Robot Forum

1 Replies
786 Views
Last post August 07, 2017, 02:38:52 AM
by SkyeFire
clip
KRC1 Mastering problems

Started by Florin199221 on KUKA Robot Forum

3 Replies
2179 Views
Last post January 30, 2016, 12:46:44 AM
by panic mode
xx
Problems with axes 4,5,6 after mastering at zero

Started by fuser33 on Fanuc Robot Forum

9 Replies
2255 Views
Last post March 22, 2017, 07:18:45 PM
by Iowan