February 17, 2019, 07:54:55 AM
Robotforum | Industrial Robots Community

 VisionTech / Attribute Assembler

Author Topic:  VisionTech / Attribute Assembler  (Read 231 times)

0 Members and 1 Guest are viewing this topic.

February 01, 2019, 09:42:22 AM
Read 231 times
Offline

zicki_88


Hi

I'm trying to set up an data matrix reading software using an MXG20 camera and VisionTech v3.1.3.
Robot is KR 8 R1420 arc HW KRC v8.3.37

As help i have 07_CodeReading.pdf documentation from the VisionTech Samples folder.

Problem I have is I can't get the AttributeAssembler to work. It is giving me an error that the input terminal "Result" is not set or does not contain a valid value. See attached Pic1.

Inside the assembler tool I have only made an link from Result (IN) to Result (OUT). Should I do any more linking here? (Pic2)

In the Image input field I added an Result terminal (VisionTechResult2D) and linked it to the attribute assembler Result terminal. (Pic3) Is this done correct?


I have read the VisionTech documentation but can't find what I'm doing wrong so please help me.
Information I need for the robot is
Result found (bool)
Result Decoded (bool)
Result Decoded (string)
Result X pos (double)
Result Y pos (double)

Also please let me know if I have to use som sort of C coding to get this done.

-zicki

 

Today at 07:54:55 AM
Reply #1

Advertisement

Guest

February 01, 2019, 01:23:53 PM
Reply #1
Offline

PJonHar


Could you attach the toolblock and an image?

February 01, 2019, 01:32:17 PM
Reply #2
Offline

zicki_88


Hi

Didn't quiet understand your answer there PJonHar....

Added an snapshot of how its done in the  07_CodeReading.pdf document.
As I earlier mention I added an VisionTechResult2D Result to the Inputs toolblock and linked it to the AttributeAssembler.Result terminal but it didn't work.

Please help.

-zicki

February 01, 2019, 01:59:14 PM
Reply #3
Offline

PJonHar


I mean upload the toolblock and a code sample image to the forum, so i can open it in workvisual.

February 04, 2019, 07:12:53 AM
Reply #4
Offline

zicki_88


Aaa of course.

Hear you go...

-zicki

February 04, 2019, 09:12:32 AM
Reply #5
Offline

PJonHar


The Result the AttributeAssembler is looking for is a Result of finding the object in question (i.e. the Succeeded,X,Y etc.).
You were simply going straight for the DataMatrix which does not produce a Result.
I have modified the VisionTech Sample for you, not sure what you want to output, but this one gets the Result (position, string etc.).
Updated: Results in Toolblock.
« Last Edit: February 04, 2019, 10:23:13 AM by PJonHar »

February 06, 2019, 09:11:00 AM
Reply #6
Offline

PJonHar



Today at 07:54:55 AM
Reply #7

Advertisement

Guest


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Teach Pendant Program Attribute 'Storage'

Started by locobot on Fanuc Robot Forum

1 Replies
1891 Views
Last post April 14, 2014, 02:36:20 PM
by locobot
clip
VisionTech : search of base

Started by yjagor on KUKA Robot Forum

3 Replies
1484 Views
Last post May 19, 2017, 02:18:25 PM
by SkyeFire
xx
VisionTech live image

Started by zicki_88 on KUKA Robot Forum

3 Replies
265 Views
Last post November 19, 2018, 04:05:05 PM
by panic mode
clip
VisionTech Calibration Grids

Started by SkyeFire on KUKA Robot Forum

4 Replies
604 Views
Last post May 11, 2018, 12:30:14 PM
by SkyeFire