February 17, 2019, 08:04:28 AM
Robotforum | Industrial Robots Community

 Using Automatic External

Author Topic:  Using Automatic External  (Read 5636 times)

0 Members and 1 Guest are viewing this topic.

April 28, 2015, 01:28:37 PM
Read 5636 times
Offline

puneeth.r18


Hi All,

My Controller Details: KRC4
Firmware Version: KS 8.3.13

Problem: 1) The robot does not select the program no in the CELL.SCR when in Automatic mode.

I have gone through this forum and found http://www.robot-forum.com/robotforum/kuka-robot-forum/external-start-stop-without-a-plc/ this post help helpful, but I am unable to get it running.

I have seen the timing diagram in the SI integrator manual and do exactly the same.
Steps that I follow:
                             1) Select the program CELL.SCR, when IN T1 mode.
                             2) Run it till it reaches home position, when IN T1 mode.
                             3) Select the EXT mode on the teach pendent.
                             4) Set $DRIVES_ON to TRUE and WAIT for $PERI_RDY to TRUE & then set $DRIVES_ON to FALSE. This is what I understood from the timing diag.(Some post suggest to set $DRIVES_ON as pulse,but at what
                             5) Set $CONF_MESS to TRUE, WAIT for $STOPMESS FALSE, set $CONF_MESS to FALSE
                             6) Set $EXT_START to TRUE, (According to the manual I need to reset $EXT_START after $PRO_ACT, but this never turns on and strangely $PGNO_REQ is always on)
                             7) Set $EXT_START to FALSE when $PGNO_REG is TRUE
                             8) I send PGNO as "1" and PGNO_PARITY as "1"(The PGNO_PARITY is confusing for me as what to set)
                             9) Wait for 100ms send PGNO_VALID = TRUE
                             10) I get a message to reset PGNO_VALID, i do it then I get message to turn on PGNO_VALID this runs in loop.(The current pointer in CELL.SCR is at P00 before the switch statement)

What am I doing wrong? Please help me in this regards.


Today at 08:04:28 AM
Reply #1

Advertisement

Guest

April 28, 2015, 08:51:22 PM
Reply #1
Offline

panic mode

Global Moderator
if you don't want to use parity, set it to zero, otherwise you must compute it on PLC end.

1) http://www.robot-forum.com/robotforum/kuka-robot-forum/read-first/
2) if you want reply about robot, post it in forum
3) read 1 and 2

April 29, 2015, 06:19:30 AM
Reply #2
Offline

puneeth.r18


@Panic_mode

Ok I now know how to calculate the parity. But the question is why does the robot loops around PGNO_VALID?

April 29, 2015, 11:37:03 AM
Reply #3
Offline

panic mode

Global Moderator
did you adapt CELL.SRC, what is called when PGNO=1?

April 30, 2015, 09:30:03 AM
Reply #4
Offline

puneeth.r18


@ Panic mode

Yes I was stupid enough and had forgotten to un-comment inside the select case :wallbash:.

Now everything works like a charm. :top:

April 20, 2016, 07:39:15 AM
Reply #5
Offline

MetsaToll


Above mentioned topic “external-start-stop-without-a-plc “ is giving:
“The topic or board you are looking for appears to be either missing or off limits to you.”
Is it possible to see it? If then how?

February 11, 2019, 06:29:12 AM
Reply #6
Offline

doubravacek



Today at 08:04:28 AM
Reply #7

Advertisement

Guest

February 11, 2019, 02:58:08 PM
Reply #7
Offline

SkyeFire

Global Moderator
Unlikely, a lot of threads were lost during the forum migrations.

What do you need to know?

February 12, 2019, 05:57:54 AM
Reply #8
Offline

panic mode

Global Moderator
« Last Edit: February 12, 2019, 02:21:57 PM by SkyeFire »

February 13, 2019, 09:05:01 AM
Reply #9
Offline

doubravacek


I need to controll robot with pushbuttons.

Interrupt robot moving by opening robot cell (it works via X11), enter, check CNC lathe (tools etc.), exit, close robot cell, reset safety and continue robot program from the point where robot was stopped.

February 13, 2019, 02:49:22 PM
Reply #10
Offline

SkyeFire

Global Moderator
That can be done with either EXT or AUT modes.  It all depends on how you configure your I/O signals.
If you want to avoid the SmartPad entirely, you'll need to use EXT mode.  You'll simply have to connect buttons for each of the Auto-External signals that would otherwise be provided by a remote PLC. 
Selecting the program would have to be done on the SmartPad, but after that, it should be possible to run the robot indefinitely without touching the SmartPad again unless something seriously unusual happens.
You will need to observe the SmartPad in order to see any error messages that crop up.


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
KR C4 Automatic External

Started by iDio on KUKA Robot Forum

26 Replies
2225 Views
Last post May 03, 2018, 10:43:55 PM
by SkyeFire
xx
Automatic external

Started by apakrat13 on KUKA Robot Forum

4 Replies
414 Views
Last post November 09, 2018, 01:48:19 AM
by apakrat13
question
External automatic values

Started by ale_t91 on KUKA Robot Forum

2 Replies
1512 Views
Last post September 08, 2015, 09:56:26 PM
by panic mode
xx
Automatic External Connection

Started by hydra on KUKA Robot Forum

2 Replies
2417 Views
Last post September 04, 2013, 02:03:41 PM
by hydra