June 27, 2019, 08:57:28 AM
Robotforum | Industrial Robots Community

 Problem while doing EMT (re)mastering of a turntable (E2)

normal_post Author Topic:  Problem while doing EMT (re)mastering of a turntable (E2)  (Read 262 times)

0 Members and 1 Guest are viewing this topic.

May 17, 2019, 06:09:55 PM
Read 262 times
Offline

lionpeloux


Hello,

I am working on a :

- KR500-2-MT with KRC2 ed2005 / KSS 5.6
- a linear unit (E1)
- a simple turntable (E2)

Today I successfully remastered A1-A6 and E1 doing the EMT mastering procedure. Unfortunately, it does not work with the turntable : the mastering gauge passes through the V-notch correctly, the green leds go on/off correctly and in correct order but the process does not stop has it should just after passing the bottom of the V-notch. Unless, it goes on until the HMI says that the limit for mastering has been reached.

I have no ideas why I encounter this problem and how It could be solved. The notch looks fine. The EMT is working fine on the others axis. Any help/tips would be appreciate.


Today at 08:57:28 AM
Reply #1

Advertisement

Guest

May 17, 2019, 06:59:41 PM
Reply #1
Offline

panic mode

Global Moderator
how many RDCs are in your system?  on KRC2 EMT must be connected to same RDC as the axis that is being mastered.

1) http://www.robot-forum.com/robotforum/kuka-robot-forum/read-first/
2) if you want reply about robot, post it in forum
3) read 1 and 2

May 20, 2019, 01:27:16 PM
Reply #2
Offline

SkyeFire

Global Moderator
Any history on this turntable, how well it Mastered before?  Is this a KUKA-made turntable, or 3rd party?

The most likely reasons for a Mastering failure are mechanical.  You could try reducing $VEL_AX_JUS[8] to slow down the mastering motion for E2.  Also check how well the gauge notch is perpendicular to the motion of the EMT pin -- a very small rotation there can cause this kind of error.

Also, try poking the gauge pin in with something plastic and feel the behavior of the pin while someone slowly (1-3%) jogs E2 past the mastering position.  You should feel a sharp, crisp transition between downward and upward motion at the bottom of the notch.  Any "lag" at the bottom of the notch will cause the kind of error you're describing.

May 21, 2019, 01:07:25 PM
Reply #3
Offline

lionpeloux


Ok, I was thinking that this robot was equipped with a single RDC because it has 8 axis. But in fact it has 2 RDCs, one for the robot + linear unit, and one for the table.

I've found the box inside the table and managed to achieve the EMT calibration properly this morning.
Thank you for your valuable help.

May 21, 2019, 04:34:40 PM
Reply #4
Offline

SkyeFire

Global Moderator
2 RDCs for only 8 axes?  That's a bit odd.  How many servos are on this controller?  Do any of the axes use dual servo motors?

May 22, 2019, 06:53:23 AM
Reply #5
Offline

lionpeloux


Ok, I got the main cabinet plus an extension cabinet.

In the main cabinet, corresponding to DSE-1, I got one KPS + 7 KSD
In the extension cabinet, corresponding to DSE-2, I got one KPS + 2 KSD. But only one seems to be active (the other one is unplugged and leds are off).

May 22, 2019, 11:34:53 AM
Reply #6
Offline

SkyeFire

Global Moderator
Ah.  I would say that this robot had 9 axes at one point in the past, or possibly used a double-servo axis.  Normally, A1-A6 and E1-E2 would be on RDC1, and only E3-E6 would be on RDC2. 

Today at 08:57:28 AM
Reply #7

Advertisement

Guest


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

question
Mastering problem

Started by zsampe on KUKA Robot Forum

4 Replies
1198 Views
Last post October 06, 2017, 04:45:45 PM
by zsampe
clip
Control speed of turntable (E2)

Started by lionpeloux on KUKA Robot Forum

1 Replies
275 Views
Last post November 28, 2018, 03:26:43 PM
by SkyeFire
xx
Control speed of turntable

Started by todm on Yaskawa Motoman Robot Forum

0 Replies
243 Views
Last post January 23, 2019, 09:51:25 AM
by todm
xx
User frame on turntable

Started by mymotoman on Yaskawa Motoman Robot Forum

2 Replies
292 Views
Last post May 20, 2019, 05:08:52 AM
by mymotoman