April 26, 2019, 04:01:52 AM
Robotforum | Industrial Robots Community

 KRC2 external emergency stop, emergency stop

Author Topic:  KRC2 external emergency stop, emergency stop  (Read 2710 times)

0 Members and 1 Guest are viewing this topic.

January 09, 2018, 05:26:24 AM
Read 2710 times
Offline

kaneyja


hello? i need your help.
please help me..

i have KRC2 210, KSS 4.1.7 version

error message like below

No.  Source  Message
  1      KS     EMERGENCY STOP
 20     KS     External Emergency Stop Pressed
284             Acc-voltage at PM1 below 22 during last buffering.

i think no.284 message that batteries voltage is low.
but i don't know No.1, 20 (Emergency message)

Robot is used well and the only thing that has been replaced is dse card.
I took the esc board apart to solve the problem I had before, but I assembled it as it was.

and I checked the x11 connector, but I don't think it's a problem.

What else could be caused?
thanks.

« Last Edit: January 10, 2018, 08:22:02 AM by kaneyja »

Today at 04:01:52 AM
Reply #1

Advertisement

Guest

January 09, 2018, 06:53:03 AM
Reply #1
Offline

Serpantinas


Hi,

Yes, the last message seems to be because of low battery voltage (see attachment).
I don't know how all the wiring in the cabinet is made and can low battery voltage cause emergency stop errors, but I think you should check the battery voltage first and if it's bad and can't be charged anymore change it.

January 09, 2018, 08:06:34 AM
Reply #2
Offline

kaneyja


i checked battery voltage.
there are two batteries and voltage are 12V, 11.8V.
i think that is okay.
is that problem?

p.s
When I turn off the power, the computer slowly turns off after waiting.
« Last Edit: January 09, 2018, 08:08:33 AM by kaneyja »

January 09, 2018, 09:01:44 AM
Reply #3
Offline

Martin84


Hello

You did not specify whether it was the BMW standard, the picture you attached shows that it is from the BMW standard.so if the BMW standard is the attachment "x11 and x13 bmw.png".If it is not a BMW standard, then the attachment "X11 standalone.png"
« Last Edit: January 09, 2018, 09:17:17 AM by Martin84 »

January 09, 2018, 12:31:15 PM
Reply #4
Offline

Serpantinas


Hey,

If you measure voltage when battery is disconnected, 12V batteries should be around 13V when charged and now you have only 12V which is practically discharged, but I'm not pro in this field so my advice is to check with someone if battery is dead or just discharged.

January 09, 2018, 11:38:26 PM
Reply #5
Offline

kaneyja


Martin84

 Thanks you! and Sorry for my mistake.
it is not BMW standard. stand alone is right.
But I don't know when the BMW standard is used.


Serpantinas

 Thanks you!
I understand. I'll consider replacing the battery.


But I want to activate the robot, do you have any other solutions?

January 10, 2018, 04:27:33 AM
Reply #6
Offline

kaneyja


The old battery was replaced with a new one.
So the low voltage message was deleted.
But there are emergency stop, external emergency stop pressed messages.
please help.

Today at 04:01:52 AM
Reply #7

Advertisement

Guest

January 10, 2018, 08:52:41 AM
Reply #7
Offline

Martin84


If you have the BWM standard, then you should have a sticker of this type on the robot, or in the documentation of the robot (Which should be in the control cabinet in the door) on the first page, as in the picture you should see that this is a BMW project.

January 10, 2018, 08:55:56 AM
Reply #8
Offline

Martin84


If this is not a bmw standard, then here is a schematic of how to properly bridge the x11 plug-in.

January 10, 2018, 09:24:51 AM
Reply #9
Offline

Blue Bird


What is the indication light status on KPS600?
Are the red lights are constantly on or flashing fast?

DO you know that there is a small black button on ESC board,
press this button for 3 seconds and then release.

Try to replace KPS600.

January 11, 2018, 07:29:47 AM
Reply #10
Offline

kaneyja


Martin84

Thank you!
Now I understand. in my case. stand alone is right.



Love Bird

KPS-600. green light blink about 1.5Hz, and two red led blink fast.

when i push black button, robot state change like emergency.
and i release black button, robot state change like nomal state.
but Still there are emergency messages.
« Last Edit: January 11, 2018, 07:44:31 AM by kaneyja »

January 11, 2018, 07:57:20 AM
Reply #11
Offline

Martin84


Did you bridge the x11 plugin yourself, from this schema what did you send?evidently it is seen that it is poorly bridged. this error is talking about it "20     KS     External Emergency Stop Pressed".
« Last Edit: January 11, 2018, 08:00:06 AM by Martin84 »

January 11, 2018, 11:16:11 PM
Reply #12
Offline

kaneyja


X11 is not my connection but someone else. and it's stand alone.
It was connected at the time of purchase.
It is used well before and the only change is the dse card.
Suddenly an emergency message appeared.



and i checked its connection like below

1-2   Test output A, Local E-STOP channel B IN
3-4   Local E-STOP channel B OUT, External E-STOP cahnnel A
5-6   Test output A, Enabling switch channel A
7-8   Test output A, Safeguard channel A

19-20   Test output B, Local E-STOP channel A IN
21-22   Local E-STOP channel A OUT, External E-STOP channel B
23-24   Test output B, Enabling switch channel B
25-26   Test output B, Safeguard channel B

38-50   Test output A, Qualifying input channel A
39-51   Test output B, Qualifying input channel B

41-42   Test output A, Drives OFF external

88-106   VCC ESC external, 24 V Internal
89-107   GND ESC external,  0 V Internal



Not only External Emergency Stop Pressed but also EMERGENCY STOP.
I am suspicious of esc board. or connection.
« Last Edit: January 12, 2018, 01:37:53 AM by kaneyja »

January 12, 2018, 05:30:22 AM
Reply #13
Offline

Blue Bird


I don't think that replacing DSE card is the cause of these emergency messages.
KPS-600 fast blinking red lights can be assumes fine working of KPS.

Can you replace your ESC card?
Do you have any KCP coupler card installed before ESC for KCP connection?

Today at 04:01:52 AM
Reply #14

Advertisement

Guest

January 12, 2018, 02:19:51 PM
Reply #14
Offline

vvelikov


can you post a photo of the bottom of the cabinet? Make sure the sockets are visible?
The design is a pleasure

January 15, 2018, 01:59:46 AM
Reply #15
Offline

kaneyja


Love Bird

  Thank your reply.
The esc board has not been replaced, but has been dismantled and assembled before.
And since it is an old version, it appears there are no boards to connect kcp.
but Kcp and esc board are directly connected.
I have not tried to replace the esc board because I don't have any spare, but I asked for repair it.


vvelikov

 Thanks.
I don't know what you want to check, I attached photo.

p.s
As the esc board is currently in repair, some lines are not connected.
« Last Edit: January 15, 2018, 07:37:18 AM by kaneyja »

January 17, 2018, 11:22:39 PM
Reply #16
Offline

kaneyja


When mfc card was replaced, all problems were solved.
Thanks all.


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
External Emergency Stop

Started by GeminiChris on Fanuc Robot Forum

4 Replies
925 Views
Last post August 21, 2018, 06:38:46 PM
by GeminiChris
xx
External Emergency stop timing in KRC-4

Started by pancholiph on KUKA Robot Forum

1 Replies
1630 Views
Last post November 30, 2015, 01:11:14 PM
by panic mode
xx
Restart RSI After External Emergency Stop

Started by bwait on KUKA Robot Forum

2 Replies
531 Views
Last post May 18, 2018, 12:43:20 PM
by SkyeFire
clip
Problem with Emergency Stop on ESC card (KRC2 ED 05)

Started by remi38200 on KUKA Robot Forum

4 Replies
4283 Views
Last post February 03, 2015, 12:55:34 AM
by panic mode