May 25, 2019, 02:24:07 AM
Robotforum | Industrial Robots Community

 Welding robot FA006, controller D, no welding in Repeat mode.

normal_post Author Topic:  Welding robot FA006, controller D, no welding in Repeat mode.  (Read 1370 times)

0 Members and 1 Guest are viewing this topic.

April 03, 2018, 06:42:04 PM
Read 1370 times
Offline

wakoru


Help is needed!
We configure the formerly used robot FA006, controller D40F-E002, the source Fronius TS4000C, ROB5000
The problem is the following: in TEACH mode, when the WELD ON / OFF button is pressed, the welding process works. When the program is started in the REPEAT mode, the robot performs all movements but no welding takes place. At the same time, no errors are indicated. It looks like a simulation mode. If you press WELD ON / OFF at this point, the welding starts. That is, physically the signal passes through the interface to the source.
Tell me where to look for the reason?
 ???

Today at 02:24:07 AM
Reply #1

Advertisement

Guest

April 03, 2018, 06:54:25 PM
Reply #1
Offline

kwakisaki

Global Moderator
How is the process programmed - in BLOCK or AS?

April 03, 2018, 09:11:09 PM
Reply #2
Offline

wakoru



April 04, 2018, 05:39:34 PM
Reply #3
Offline

kwakisaki

Global Moderator
Your Fronius connection - how is this connected to the Kawasaki - Hard wired IO or communication over fieldbus?

April 05, 2018, 09:57:17 AM
Reply #4
Offline

wakoru


inteface ROB5000
I inserted into the block program of the AS command arc on and arc off, the welding began to work.
« Last Edit: April 05, 2018, 10:00:46 AM by wakoru »

April 05, 2018, 05:32:44 PM
Reply #5
Offline

kwakisaki

Global Moderator
 :top:.........Good man.

By using it in the program instruction format, you can obviously control it within the program (as you've used it).
I have come across scenarios where the arc system switch is permanently on in Aux 0502.
- Thus relying totally on the welder interface dedicated signal exchange for welding.
- But a PC task running in the background monitoring for Emergency Stop Conditions and if in Emergency Stop, turning Arc Off.
- Application and Configuration dependent of course.

January 11, 2019, 12:50:43 PM
Reply #6
Offline

glory00


Dear All,

currently, i have this problem with BA06L with E controller.

it was working perfectly in checking and automatic mode, but suddenly the robot just moves without any welding and without any error.

please advise ??

Today at 02:24:07 AM
Reply #7

Advertisement

Guest

January 11, 2019, 02:36:21 PM
Reply #7
Offline

kwakisaki

Global Moderator
Check ARC ON system switch is activated (you should be able to see this on Teach Pendant in Function Tab screen - See attached).
- If this is OFF (greyed out), the robot will run the program as intended without welding/sending the applicable signals to the weld set.

If this is ON, then you need to check dedicated signals are being sent to weld set to initiate weld.
« Last Edit: January 11, 2019, 02:55:53 PM by kwakisaki »


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Welding defect Repeat the point

Started by El masters on KUKA Robot Forum

10 Replies
1867 Views
Last post August 27, 2017, 03:47:59 PM
by panic mode
xx
Controller for custom welding robot

Started by dpac18 on General Discussion of Industrial Robots Only

1 Replies
705 Views
Last post August 01, 2017, 02:36:21 PM
by SkyeFire
xx
communication error between welding controller and robot gun

Started by Hefei on other Robots

0 Replies
1174 Views
Last post September 01, 2014, 03:31:28 PM
by Hefei
xx
Arc welding robot 120ic with controller R30ib Collision

Started by srjd on Fanuc Robot Forum

4 Replies
676 Views
Last post June 04, 2018, 12:46:34 AM
by Racermike123