June 18, 2019, 03:50:38 PM
Robotforum | Industrial Robots Community

 Connect issue KRTerm AS programing

normal_post Author Topic:  Connect issue KRTerm AS programing  (Read 382 times)

0 Members and 1 Guest are viewing this topic.

April 16, 2019, 06:50:48 PM
Read 382 times
Offline

elvicash


Fairly new Kawasaki user. Just back from Wixom Kawasaki Integrator class which covered some basics such as block programming and intro to editing AS from KRTerm. I am back at our shop and trying to repeat what I learned. I am online with the controller via Ethernet and am using KRTerm 1.2.8  The robot is a R20 on an E controller all brandnew.

I can do a save and make a backup so I know I am connected.   I can do a type "hello" it prints out hello but that is all I can do from the command prompt

Any other operation fails with a P1062 Operation not permitted.

I tried to do an edit myprog  to edit a routine

I tried aaa = 31  to create a variable

Any help with this would be appreciated

Thanks

Today at 03:50:38 PM
Reply #1

Advertisement

Guest

April 16, 2019, 07:04:19 PM
Reply #1
Offline

Kawaguy


Looks like your robot is protected. Which user level is set? You can see it in the top section of the screen.  LVL1/2 or 3. Can you change your user level in aux-menu 8-98?

April 16, 2019, 07:28:36 PM
Reply #2
Offline

elvicash


I can make it a 1 or 2 when I enter a 3 it says the number is out of range

April 17, 2019, 12:32:45 PM
Reply #3
Offline

elvicash


After reviewing this thread
https://www.robot-forum.com/robotforum/kawasaki-robot-support-forum/operational-level-change-in-e-controller/msg62334/#msg62334

I can set the user level to 3

Press R Code Input page  899  ENTER

Level 3 in the first Box and hit ENTER
Enter Password 9894 and that enables Level 3  on my E controller

Thanks JBHiker

Now we will find out if that fixes my KRTerm issue stay tuned

April 17, 2019, 01:49:22 PM
Reply #4
Offline

elvicash


I sent in my backup to Kawasaki and they reviewed it and found out my controller has a safety function included usually used by large automotive customers. This disables the KRTerm for some reason, this can be turned off so from a connect KRTerm session enter the following

ZENATELNET ON    press Enter

Viola the KRTerm is now working 

Thanks Kawasaki  it all good for now

April 17, 2019, 07:35:44 PM
Reply #5
Offline

kwakisaki

Global Moderator
Dam......just beat me.

Yes, I was going to suggest the ZENATELNET switch.
I have experienced this many times with American spec controllers (never seen this on European Controllers).
- Is yours American Spec by any chance then?

April 19, 2019, 01:21:25 PM
Reply #6
Offline

elvicash




Yes I have the American Spec and the controller was configured per a large automotive company order, we needed a robot quickly and they pulled this one for us off the stock on the floor. I think the standard Americna version does not require the ZENATELNET ON command.

Also this has to be entered after any reboot, The change can be made permanent but it will require a Kawasaki tech to make that change.

Today at 03:50:38 PM
Reply #7

Advertisement

Guest

April 19, 2019, 07:03:19 PM
Reply #7
Offline

kwakisaki

Global Moderator
I  can't remember whether this is in the firmware or within file save data, as it may also set another switch, so that the setting is not retained on a power cycle.

Turn your controller on without it enabled and a take a full file save.
Then enable it and take another full file save.
- Use Winmerge or another text comparison app and see what differences there are.
- If indeed another switch is also set, you should be able to mod the file save and load it back in to make it permanent.
- Not 100% sure, but it would be worth looking at both sets of file save data to see.



Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

question
Communicating Krterm and Matlab

Started by Homer1001 on Kawasaki Robot Support Forum

5 Replies
5157 Views
Last post June 10, 2016, 09:06:56 AM
by BCITokyo
question
AD-controller and Online Terminal Editors. It possible with KRterm?

Started by Arcisz Arcisz on Kawasaki Robot Support Forum

2 Replies
184 Views
Last post May 27, 2019, 10:30:54 PM
by Kawaguy
xx
Need help programing

Started by bcchips on Fanuc Robot Forum

1 Replies
2531 Views
Last post March 05, 2013, 07:41:18 PM
by Tyler Robertson
xx
KR C1 - AUT EXT - Programing - I/O without PLC

Started by tnrj on KUKA Robot Forum

13 Replies
6565 Views
Last post August 20, 2013, 03:37:44 PM
by SkyeFire