March 20, 2019, 01:53:19 AM
Robotforum | Industrial Robots Community

 srvo 073

Author Topic:  srvo 073  (Read 647 times)

0 Members and 1 Guest are viewing this topic.

January 07, 2019, 11:39:17 PM
Read 647 times


I am very new to Fanuc and I am having a consistent problem with a srvo-073 fault on a 430i robot.  I am just in the learning stages of using this robot but when I put it thru the motions, it will fault srvo-073 Axis 3 CMAL. I have the manual and all it says is "master the robot" .
 Well I have done a cold restart and after a few times, it comes back to the point I can jog it again.  I have configured my cables  so they aren't coiled and moved them so they are not close to any hi voltage cables and still get the faults.  I'm talking more fault time than jogging time. Another thread talks about "better shielding", what are they suggesting, I don't know.  Any help would be appreciated.

Today at 01:53:19 AM
Reply #1



January 08, 2019, 05:17:03 AM
Reply #1


Have you tried to reset the pulse coder? Check the cable on axis 3 for damage. I would try to get the robot to zero position then check the connection on axis 3

January 08, 2019, 06:46:17 AM
Reply #2


Just a short question here: that is the ONLY error that the robot is showing? I've had this on an R2000 but it came with a whole sleuth of other errors to check.

January 08, 2019, 09:20:35 PM
Reply #3


Check for electrical noise.
Make sure the robot is grounded to the controller. Make sure the robot cables are grounded in the controller using the ground clamp.  Make sure the ground bar has a good ground.   Check the ground strap from the back of the robot and behind the Harting connectors.

January 08, 2019, 11:04:44 PM
Reply #4


Thanks everyone.  I will check all those things tomorrow afternoon.  The only question I have is when I'm checking the cable for axis 3, are we talking about the cable that passes thru the frame up to the servo motor? yea I suppose if there were a chafe it would mess things up. I will check that out also.

January 09, 2019, 12:34:26 AM
Reply #5


I forgot, yes this is the only fault that is indicated. I saw in the manual if other faults were active to check them first but this was the only one and it is frustrating.

January 09, 2019, 11:55:38 PM
Reply #6


Well all the good intentions I had for this afternoon kinda got side lined.  I did get a ground from the controller to the building ground, I already had a ground to the robot. After about 6 cold starts attempts  I still could not get rid of the srvo-073 fault.  I had to do a pulse counter reset and then a cold restart and got control of the robot in jog.  That lasted about 20 minuets and then srvo-073.  I did notice it seemed to have happened on a J-3 minus move.  Thinking back, I'm thinking they all occurred during a j-3 minus jog.  The full alarm indication is SRVO-073 CMAL (Group:1 Axis:3).  I hope to be able to do a cable inspection from the base to the servo motor on fri.  on axis 3.  Does anyone know if the encoder cable from the motor to the harting connector is shielded and what the specs for that cable are?

Also the srvo-073 alarm says in the book there is a mis-match in the pulse coder for that axis.  Is there some way to pull those numbers up on the TP to see?

I am going to check those ground connections behind the harting connector and in the controller cabinet.  But I'm leaning towards the cableing to J-3. What do you guys think?

Today at 01:53:19 AM
Reply #7



January 10, 2019, 01:00:55 AM
Reply #7


Try reseating connectors CRF1 on the servo amp and RP1 at the base of the robot.  If you checked the grounding (including the connector RP1 ground wire inside the robot base) as suggested by JimFc, then I would want to rule out the J3 PulseCoder before the cable harness.  PulseCoders have bearings that wear, glass that gets dirty, and sensors & other components that weaken with age.  If there isn't a spare PulseCoder you can use, you can swap J2 & J3 PulseCoders and see if the problem follows.  Only do the swap if you highly confident on how to single-axis master back to a recordered position.  If not, instructions can easily be posted.

January 12, 2019, 07:24:11 PM
Reply #8


Well guys, checking those grounds was the answer.  I was able to jog the robot and put in a small program yesterday and it ran all day. 
Now I'm moving on to my next problem but will start another post.  Thanks all for your help.

Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

Control Stop(SRVO-199) and Fence Open(SRVO-004) Alarm.

Started by Atinder on Fanuc Robot Forum

5 Replies
Last post January 03, 2018, 07:04:37 AM
by rafahil
Fanuc Collaborative Robot Error SRVO-496 SRVO-497

Started by fluke on Fanuc Robot Forum

0 Replies
Last post Yesterday at 08:07:49 PM
by fluke
Fanuc R-30iA SRVO-043 and SRVO-105

Started by steve_88vd on Fanuc Robot Forum

4 Replies
Last post May 14, 2018, 05:09:33 AM
by steve_88vd
SRVO-269 and SRVO-280 error codes

Started by emery606 on Fanuc Robot Forum

1 Replies
Last post September 18, 2018, 05:18:13 PM
by HawkME