May 26, 2019, 09:59:45 AM
Robotforum | Industrial Robots Community

 Problem with Fanuc 420iW booting

normal_post Author Topic:  Problem with Fanuc 420iW booting  (Read 2527 times)

0 Members and 1 Guest are viewing this topic.

October 16, 2017, 07:30:53 PM
Read 2527 times
Offline

kosternet


 :help:

Hi there everyone,

I want to start programming for a Fanuc-robot. I found a robot online and got it shipped to a location where I can test the robot.

I have replaced the CEE-connector and plugged it in. When I switch on the main switch nothing happens. When I press the ON-button, the different FAN's startup.. The TeachPendant starts up, but gives a blank screen after the message 'Checksum (blablablalong)'. Nothing seems to happen...
Look at this nice video-compilation I have created: https://photos.app.goo.gl/pTrVMZXnkB6qEOir2

Today I got some extra tools and managed to open the R-J2 controller. Inside some lights start flickering, but the party ends with the following configuration:
Green:
ON off ON off
Red:
ON ON ON
(Again a short video-compilation : https://photos.app.goo.gl/nxmdAMLplBTKqFo22 )

I have asked the guy I bought the robot from, and he told me they had it working three years ago.

When reading around I read that possibly the battery went down in the last years, having the memory erased.. Would that mean that I have just bought a very expensive presse-papier?  :icon_rolleyes:

I hope any of you can help me out!

(And yes, this is an other one of the Belgian Opel-Fanuc 420iW robot arms. Precision is not really important for me, I am just trying to learn how to control a robot like this from PC.)

Today at 09:59:45 AM
Reply #1

Advertisement

Guest

October 16, 2017, 08:02:07 PM
Reply #1
Offline

cejka


Hello there, I'm just going through the simmilar process with my Fanuc S700 but with RH controller. As far as I know from documentation if you don't replace batteries every year it will be drained by CMOS RAM board and thus it will be erased and no software and settings will stay in there.

October 17, 2017, 05:29:21 PM
Reply #2
Offline

kosternet


Okay. Thanks for your reply.

And is there any way to get the software back on the machine?

Kind regards,
Geert

October 17, 2017, 07:25:59 PM
Reply #3
Offline

rafahil


If the Main board and daughter boards are OK, you will recover the robot functionaliy reinstaling the core software from floppy disk or K-floppy. and then restoring a backup (in case you have it). If you do not have the core software, fanuc can make it. I do know the cost.

October 17, 2017, 08:34:05 PM
Reply #4
Offline

cejka


@kosternet

Sure it can be loaded back into controller. I suppose you have R-J2. I don't know it but I think the process will be simmilar to the R-H. So I tell you what I have to do to get my software back. You may find it usefull.

As a robot's controller do behave as classic PC I'm sure you know well there is a BootROM mode (at PC known as BIOS). It is stored inside EPROMs which lies on one of the board (Shared RAM Board) on controller. Mine is labeled as 2.22PA. That means that controller has BootROM version 2.22P Rev. A. After you start the controller which has no software in it it will goes directly to BootROM mode. If not the USER PB #1 and USER PB #2 buttons have to be pressed while pressing Power ON button.

You did not mention if your controller has CRT monitor with keyboard. If not it is important to get or make some RS-232 cable to be able to establish communication between ordinary PC and controller to see what is going inside and send commands what to do using some VT220 emulator - some PUTTY like software or simmilar. Without CRT or PC cable you'll not be able to set the controller back to operation.

Then if you set everything on BootROM mode there should be software loaded into controller CMOS RAM. CMOS RAM operates as a "harddrive" on which will be basic software (operating system) stored and will run from. If you buy the machine with software floppy discs you are half a way to success. If you did not get it from seller you are in trouble and have to buy it from FANUC. AFAIK that would be expensive. Software is robot specific because it contains specific data loaded into servos etc.

Ok you have a communication ability (CRT or cable) and have a software.

You have to have FLOPPY hardware which you'll connect to controller or you may have emulate it with KFLOPPY software. Also can be ordered from FANUC. To be able to emulate the floppy hardware you have to have another RS-232 cable, also known as KFLOPPY cable. You can buy it or make one yourself. That KFLOPPY software you will use to upload software into controller.

To upload software you power down the controller. Then push HOLD button while pressing Power ON. The controller will seek floppy diskettes with software and if you follow instructions on screen (CRT or cable with VT220 terminal emulator) the software will be strored in controller. Then after another controller power on the software will be automatically loaded and robot will be back in operation.

I'm in trouble with my CMOS RAM so I'm not able to upload any software back to the controller and check this procedure if it really works but it should. Especially for R-H controller.

October 18, 2017, 05:51:03 PM
Reply #5
Offline

mortoch


Here is the pin out for the Kfloppy cable, at least for an RJ-2 controller.
          ROBOT                                            PC
25 pin male connector                9 pin female connector
                       
   2    <--------------------------------------<   2
                       
   3    <--------------------------------------<   3
                       
   7    <--------------------------------------<   5

   6     >--|                                |--<   1
               |                                |
   8     >--|                                |--<   4
               |                                |
   20   >--|                                |--<   6

   4    >--|                                |--<   7
              |                                |
   5    >--|                                |--<   8

October 19, 2017, 01:00:11 PM
Reply #6
Offline

kosternet


Rafahil, Cejka and Mortoch,

Thanks very much!! I know what to do next. I will make this cable and check if the system CMOS-RAM is still ok. I have a system without a CRT, so I will try to get everything up and running using software on the PC.
Does any of you know if I can use a regular USB<->RS232 converter to communicate or do I need an other option.
The most exciting part will now be if I can get hold of the software anywhere...

The story continues ;-)

Regards,
Geert

Today at 09:59:45 AM
Reply #7

Advertisement

Guest

October 19, 2017, 01:35:58 PM
Reply #7
Offline

pdl


Go to ebay and buy a cheap laptop with a clean version of windows XP and a real serial port.  They can be found for under $20.
In my experience, and I've tried a lot, KFLOPPY does not work with USB>RS232 converters, even the good pcmcia with real UART.

October 19, 2017, 03:27:00 PM
Reply #8
Offline

rafahil


I have a laptop using Win7, without serial port.

I was forced to buy a DB9<->USB cable. Additionally, I had to run a Virtual PC (win XP) over the Win7.

The "most difficult" part was to link the physical USB port from my real machine to the COM port of the virtual machine. Once got this, the Kfloppy software could recognize the USB port of the real machine.

I used two cables:
To RS232 Controller port <---- [DB25<--cable-->DB9]  + [DB9<--cable-->USB] ---> To Laptop


But as pdl says, it is much easier if you get a laptop with WinXP and a real serial port

October 19, 2017, 04:43:31 PM
Reply #9
Offline

cejka


@kosternet

I can't recommend that. The USB-to-serial converters always introduces some problems if they have to work as pure serial. On my R-H controller is RS-232-C but in today's computers are RS-232-E or RS-232-F as I know. Even my serial port on laptop under Putty does not work very well with the controller. So my solution to this is to build plain old PC. This PC I'm going to mount inside controller and permanently connect it to it's RS232 ports. I'll install GNU/Linux on it, DOSbox with necessary software for communication with robot. Then I will be able to communicate with it using any computer over LAN via some ssh or nx connection. I think this is cleanest solution to avoid problems with notebok that is being updated during it's everyday usage which may lead to unnecessary problems.

Hope you'll get it to work no matter the way you choose.

October 19, 2017, 05:48:45 PM
Reply #10
Offline

mortoch


I also wound up getting an old xp with a 9 pin D port and used the cable as described. Worked like a charm.
I tried all the other options before but that route was the best option.

May 15, 2019, 04:07:50 AM
Reply #11
Offline

ADAN_SL


Hello!
I had the same problem with a robot system R-J2 Robot S-420i, it seems to damage the battery and checksum marks me and some hexadecimal value,
search and found this forum, now I do not have the main software could be that rafahil you can give me the cost of the software please, if this is not the correct forum I apologize and thank you in advance.


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

clip
DP and DS connectors S-420iW

Started by nnfuller on Fanuc Robot Forum

1 Replies
899 Views
Last post October 05, 2017, 10:07:11 PM
by tre4175
clip
R-J2 is not booting up

Started by KamilJ on Fanuc Robot Forum

0 Replies
127 Views
Last post March 01, 2019, 02:18:20 PM
by KamilJ
xx
R-30iA Not Booting up!!

Started by ESIELI on Fanuc Robot Forum

3 Replies
1449 Views
Last post July 29, 2017, 03:30:20 PM
by pdl
xx
Booting krc1

Started by cnmcreative on KUKA Robot Forum

6 Replies
2838 Views
Last post June 14, 2013, 08:51:18 PM
by SkyeFire