January 17, 2019, 05:17:09 AM
Robotforum | Industrial Robots Community

 SSO[5] C_NTED Help Needed


Author Topic:  SSO[5] C_NTED Help Needed  (Read 406 times)

0 Members and 1 Guest are viewing this topic.

October 22, 2018, 05:29:18 PM
Read 406 times
Offline

RockyLeafs


Hello,

I"m trying to use the C_NTED function over the DCS safety IO.
I have the SSO[5] tied to an SPI input [3], and the input is being made (@ symbol is shown) but I still get the DCS SSO NTED alarm whenever I try to enable the teach pendant in teach mode.
I've tried jumping out the input, and even using a different one with no success.

I've even tried tying the SSO[5] to the SSI[5], and that seems to work but once I tie any input to the SSO[5] signal it will not allow the robot servos to enable in teach.

Is there a parameter I may be missing? we are using the smaller 'b' cabinets so there is no hard wire NTED feature to get to, thats why i'm using the SPI and SSO[5] connections in the DCS safety logic.

Any guidance would help.

Linkback: https://www.robot-forum.com/robotforum/index.php?topic=29275.0
  • Like    Thanks

Today at 05:17:09 AM
Reply #1

Advertisement

Guest

October 22, 2018, 07:04:56 PM
Reply #1
Offline

jenesaisquoi


This is how I have my DCS safety IO setup (see attached). In my case, the safety signals are being controlled by the PLC.

If you're really hard pressed to jump it out, you can set SSO[5] = ON (JUST MAKE SURE YOU PUT IT BACK WHEN YOU ARE DONE TEACHING)
  • Like    Thanks

October 23, 2018, 12:19:41 PM
Reply #2
Offline

RockyLeafs


I'm not looking to jump it out permanately.
I'm looking for a solution as to why If I have any SPI input tied to SSO[5] then it doesn't work.
  • Like    Thanks

October 23, 2018, 02:17:36 PM
Reply #3
Offline

jenesaisquoi


What is controlling your safety signals? Do you have a PLC?

Because if you do, the the PLC should send you a CSI that you tie to SSO[5]. For example SSO[5] = CSI[5]

I don't typically use SPI's in DCS
  • Like    Thanks

November 02, 2018, 12:13:32 PM
Reply #4
Offline

RockyLeafs


Unfortunately on this project we do not have a Safety PLC.
The SPI had to be used as a result.

I've tried contacting Fanuc but no luck with them yet either.
  • Like    Thanks

November 02, 2018, 04:40:32 PM
Reply #5
Offline

jenesaisquoi


What is SPI[3] tied to?
  • Like    Thanks


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Sys var or command needed please

Started by Chipprogr on Fanuc Robot Forum

1 Replies
1826 Views
Last post April 29, 2013, 04:30:27 AM
by Chipprogr
xx
boot help needed

Started by Corfabrication on ABB Robot Forum

0 Replies
490 Views
Last post December 19, 2017, 02:14:29 AM
by Corfabrication
xx
Approximate help needed

Started by zicki_88 on KUKA Robot Forum

4 Replies
345 Views
Last post November 16, 2018, 05:34:38 AM
by Fubini
xx
Help Needed on loading a .TP

Started by EduardoRS on Fanuc Robot Forum

3 Replies
1195 Views
Last post June 27, 2017, 07:02:19 PM
by Lerak