January 17, 2019, 10:32:14 PM
Robotforum | Industrial Robots Community

 Rj2 Left side deadman switch not working


Author Topic:  Rj2 Left side deadman switch not working  (Read 194 times)

0 Members and 1 Guest are viewing this topic.

January 07, 2019, 04:56:52 PM
Read 194 times
Offline

manan gandhi


I have RJ2 controller for Fanuc arcmate 100i. The left side dead man switch stopped working after some external emergency switch wiring work went wrong. One of the wire of the external emergency switch was connected to the control panel’s emergency [EMR IN] and the other to 24v of PLC by mistake. The switch stopped working after that. Please help me resolve this issue.

Linkback: https://www.robot-forum.com/robotforum/index.php?topic=30241.0
  • Like    Thanks

Today at 10:32:14 PM
Reply #1

Advertisement

Guest

January 09, 2019, 05:35:44 AM
Reply #1
Offline

byrol


Hi manan,

Parallel connection is made on the switch electronic card on both sides. Even if one party doesn't work, the other party will do the job. You have made a wrong connection and if you have connected a voltage to the board, first disconnect it. Remove the non-functioning left side switch cable.
I need to check if the right side is working. If it does not work again, an electronic burnt piece from the excess voltage can be seen. Or a good electronic gauge can control the input of the switch by scanning the card. The non-rigid part can be easily detected.
Of course you need to do the same check on the "Controller Panel Board".
  • Like    Thanks

January 09, 2019, 04:10:20 PM
Reply #2
Offline

manan gandhi


Hi Byrol,

I haven’t connected or made any changes to the TP wiring. The wire that i was working was for the external emergency switch. The right side switch is still functioning without any issue.
  • Like    Thanks

January 09, 2019, 10:45:03 PM
Reply #3
Offline

Skooter


In a single chain R-J/R-J2 pendant (A05B-2301-C30x), if one deadman switch works and the other doesn't, then the problem should be in the teach pendant.
The switches are wired in parallel so my guess would be the L switch is bad, come loose, wire has come off, the metal actuator between the handle and the switch failed/bent, or a bad wire between the switch and the connector going to the control board.
If you take the back cover off, be careful to unplug the connector going to the deadman switches.
When putting the cover back on, don't forget to plug the connector back in and to not to pinch the wiring from the switches to the control board.
  • Like    Thanks


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Deadman switch not working

Started by EMSSTC on Fanuc Robot Forum

5 Replies
5380 Views
Last post October 20, 2015, 11:36:31 AM
by EMSSTC
xx
Mirroring a robot program from right side to left side robot

Started by saravanan190990 on Fanuc Robot Forum

1 Replies
1215 Views
Last post September 21, 2017, 05:50:32 PM
by guilherme.simoes
xx
deadman switch state

Started by i_robot72 on KUKA Robot Forum

5 Replies
3164 Views
Last post July 20, 2015, 04:38:03 PM
by the leg
xx
Deadman switch brake

Started by wheensy on Fanuc Robot Forum

1 Replies
1612 Views
Last post August 12, 2015, 11:55:12 AM
by shalletk