Author Topic: RJ Controller FANUC TP upload  (Read 180 times)

0 Members and 1 Guest are viewing this topic.

Offline Miss Spike

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
RJ Controller FANUC TP upload
« on: September 21, 2018, 08:37:43 PM »
Hi everyone!

I have a S-420FD Fanuc robot with a RJ controller, i was trying to load the .TP programs with the K floppy, but it wont let me and it shows a message that says that the file does not exists or it´s invalid. Also the files i was trying to upload (which are the .TP) ares saved with a .PE extension, i think that this may be the reason why i cant load it to the controller but when i did the back up the files we saved with that extension.

So could it be that i can´t upload the TP programs because of the .PE extension?, if so why did the files came out with this extension?, and is it possible to load them?

If it is not related with the .PE extension what could it be? :help:

i appreciate your help.
  :cheer:
Miss Spike

Offline bencor21

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 9
  • Posts: 50
Re: RJ Controller FANUC TP upload
« Reply #1 on: September 24, 2018, 11:04:07 AM »
.PE files are Ascii, similar to how now they are .LS files when you do an Ascii, readable files backup.  I have no clue with a controller that old is the Ascii upload option is even available.  How did you do the backup?  Menu > File > Backup > all of the above should not have backed them up in .PE format.

Offline Onequickpuck

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 13
Re: RJ Controller FANUC TP upload
« Reply #2 on: September 27, 2018, 10:12:00 PM »
With the Laptop connected and K-Floppy running, select only one or two .TP programs to backup.
Then look in the laptop directory where they land and see what they look like when they get there.

Write a couple dummy TP programs and try backing them up, then deleting the ones in the Teach Pendant, then reloading them from the laptop.

Once I learned how to use K-Floppy this was the method I used to verify that it was working properly.

I too have some RJ robots. Will send PM.