April 26, 2019, 04:02:50 AM
Robotforum | Industrial Robots Community

 PROFINET-SW and S7-1200

Author Topic:  PROFINET-SW and S7-1200  (Read 1664 times)

0 Members and 2 Guests are viewing this topic.

January 12, 2018, 05:05:10 PM
Read 1664 times
Offline

JavierBeta


Currently Im working with an IRC5 m2004 trying to make it work in automatic , right now i ran into a problem the irc5 has installed profinet-SW and doesn't have another profinet card, Im lost right now since i dont have a clue how I can control the irc5 through a plc any advice or guidance would be appreciated

Today at 04:02:50 AM
Reply #1

Advertisement

Guest

January 15, 2018, 10:57:35 AM
Reply #1
Offline

TSBV


what kind of options does your robot have? I believe on a M2004 you should have the anybus card for profnet. Can you share a picture of the main computer?

thanks,

Jeroen

January 15, 2018, 01:38:27 PM
Reply #2
Offline

Lemster68


Which version of the main computer is in your controller?  If DSQC1000, then you can connect to LAN 2 or LAN 3.

January 23, 2018, 09:33:22 PM
Reply #3
Offline

bman84


I'm just commissioning an IRC5c with an anybus profinet card, running in automatic is a case of mapping some signals, then linking them to system signals within the IO configuration in robotstudio.

January 24, 2018, 05:23:13 PM
Reply #4
Offline

TSBV


Hi,

It is not that hard. Add below in your EIO system

#
INDUSTRIAL_NETWORK:
 

    -Name "PROFINET_Anybus" -Label "PROFINET Anybus Network"\
      -Address "0.0.0.0" -SubnetMask "0.0.0.0" -Gateway "0.0.0.0"



#
PROFINET_INTERNAL_ANYBUS_DEVICE:

      -Name "PN_Internal_Anybus" -VendorName "ABB Robotics"\
      -ProductName "PROFINET Internal Anybus Device" -OutputSize 128\
      -InputSize 128



Then you can map your signals :

  -Name "doBlaBla" -SignalType "DO" -Device "PN_Internal_Anybus"\
      -Label "RobotController is switched ON" -DeviceMap "0"


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Profinet Connection KR C4 & S7-1200

Started by luketang56 on KUKA Robot Forum

10 Replies
5554 Views
Last post August 31, 2017, 07:31:18 PM
by panic mode
question
Profinet or DI/O S7-1200 to Fanuc M10iA ?

Started by stonez on Fanuc Robot Forum

9 Replies
629 Views
Last post March 13, 2019, 11:05:40 AM
by stonez
clip
S7-1200 KRC4 ROBOT (as Device) PROFINET CONFIGURATION

Started by IlFincoITA on KUKA Robot Forum

14 Replies
2927 Views
Last post February 19, 2018, 12:38:36 PM
by Etke
xx
IRB 1200 Manual

Started by mr_ruslan on ABB Robot Forum

1 Replies
661 Views
Last post January 17, 2018, 03:59:07 PM
by TSBV