March 23, 2019, 09:03:34 AM
Robotforum | Industrial Robots Community

 Event error Code to PLC

Author Topic:  Event error Code to PLC  (Read 298 times)

0 Members and 1 Guest are viewing this topic.

December 21, 2018, 12:45:07 PM
Read 298 times
Offline

Astronomist7


Hello

I want to send the error code of the event message occured to PLC, Im talking about ERRORID, is it possible? what variables should i use? because ERRNOtype ERRNUM couldnt help, im looking for event errors.

Thank you.

Today at 09:03:34 AM
Reply #1

Advertisement

Guest

December 30, 2018, 08:12:41 AM
Reply #1
Offline

Robtics


PROC rGrip_Clamp()
VAR bool bTimeover;

! Gripper Clamp Operation
Begin:
   WaitTime 0.5;
   Set Do01_Grip_Clamp;
   Reset Do02_Grip_Unclamp;
   WaitUntil Di01_Grip_Clamp = 1 AND Di02_Grip_Open = 0\MaxTime:=5\TimeFlag:=bTimeover;

   IF bTimeover = TRUE THEN
      TPErase;
      ErrWrite " PROC rGrip_Clamp ","Clamp Operation has Failed !"\RL2:=" Check Di01 and Di02 Sensor";
      SetGo Go01_Error_Code, 1;
      PulseDO\PLenght 2.0, Co44_Rob_Error;
      Stop;
      GOTO Begin;
   Else
      Gripload ldWork;
      WaitTime 1.0;
      Return;
   EndIF

   Return;
EndPROC


This sub-routine for Gripper Clamp operation.

Do signal assign DSQC652 I/O Card (Sol-valve and PX Sensor)
Co Signal assign DSQC378 CC-Link Card

that group output signal mix 1,2,4,8,18 bit.

ie... 1 is clamp error, 2 is unclamp error..

Co44 signal and bit(group) status mix and PLC programmer will be display error on GOT window. for each error kinds of number.
ABB
FANUC
KAWASAKI
HHIR

I Can handle it!


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Event code 50444

Started by Bwilson on ABB Robot Forum

4 Replies
384 Views
Last post September 28, 2018, 11:57:38 PM
by Skooter
clip
IRB 2400 "Referans error " and " 10051 Event Routine Error" help..

Started by realrobot on ABB Robot Forum

1 Replies
1874 Views
Last post April 17, 2013, 12:12:17 PM
by Doxar
xx
RH-6 Robot Error code H109(1) - (4) Servo amp initialization Error

Started by Fairview on Mitsubishi Robot Forum

0 Replies
356 Views
Last post January 03, 2019, 03:50:10 PM
by Fairview
xx
Motoman error code 1060 system error

Started by rashid on Yaskawa Motoman Robot Forum

2 Replies
759 Views
Last post December 23, 2017, 12:47:52 PM
by Robodoc