December 18, 2018, 01:29:05 PM
Robotforum | Industrial Robots Community

 Value of inputs from profinet when communication goes down


Author Topic:  Value of inputs from profinet when communication goes down  (Read 277 times)

0 Members and 1 Guest are viewing this topic.

November 20, 2018, 02:41:06 PM
Read 277 times
Offline

Plc_User


If I have IRC5 connected as Profinet device to Siemens S7 plc, and a bit in the receive area for the IRC5 is always set high from
the code of the S7 plc. When the Profinet cable is unplugged, will it have value 0 (or default value)?
I would use this for check if communication with S7 plc is still ok.

Linkback: https://www.robot-forum.com/robotforum/index.php?topic=29684.0

Today at 01:29:05 PM
Reply #1

Advertisement

Guest

November 20, 2018, 03:08:59 PM
Reply #1
Offline

Lemster68


Try the function IOUnitState to evaluate the status of the connection.

November 21, 2018, 02:00:41 PM
Reply #2
Offline

robotero


I just did that
I mapped the system I/O signals to profinet
changing the logic of the Quick STOP/ Soft STOP / STOP signals
so now the PLC must send 1 to those signals

The I/O signals take the default value wen the cable is disconnected or communicaation problem occurs
Now those signals have to functions, I can STOP the robot using those signals and also detect a cable unplugged
That robot STOPS because the signals are missing

« Last Edit: November 21, 2018, 02:04:02 PM by robotero »

November 21, 2018, 02:03:51 PM
Reply #3
Offline

Plc_User



December 05, 2018, 09:42:23 AM
Reply #4
Offline

Plc_User


I have some signals configured as analog input that come from Profinet communication sent by Siemens PLC.
I have filled in a default value different from 0.
When connection is ok, value of f.i. 56 is sent and received ok in the robot.
When I pull out the profinet cable I get value 0 in the robot.
What is the default value then used for?
How can I achieve that the default value is used when the connection is down?

Thanks.

December 06, 2018, 07:40:08 PM
Reply #5
Offline

robotero


What are your other signal parameters settings?
Like min value, logical value, etc.



Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Real inputs via Profinet and slave in the same time

Started by Casius on KUKA Robot Forum

2 Replies
2057 Views
Last post June 09, 2015, 01:45:13 PM
by Casius
clip
PROFINET Communication

Started by puneeth.r18 on KUKA Robot Forum

6 Replies
3406 Views
Last post March 12, 2016, 12:05:13 PM
by puneeth.r18
xx
ProfiNET communication problem

Started by napster on KUKA Robot Forum

1 Replies
586 Views
Last post December 01, 2017, 01:45:13 PM
by SkyeFire
xx
ProfiNet communication issue

Started by ClaudiuA on Fanuc Robot Forum

14 Replies
2858 Views
Last post May 23, 2018, 02:17:30 PM
by racido123