Author Topic: Configuring Omron NX-EIC202 to work with irb 1200  (Read 805 times)

0 Members and 1 Guest are viewing this topic.

Offline zicki_88

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 13
Configuring Omron NX-EIC202 to work with irb 1200
« on: July 31, 2017, 11:55:14 AM »
Hello

Does anyone here have some experiences using Omron NX-EIC202 IO board?

We have an upcoming project where we are planning to use NX-EIC202. I did some testes and only got the input side working. The outputs do not work correctly. Seems like there some issues with the Output Assembly parameter because the mapping is messed up.  I have tried to modify the parameters manually according to the EDS file but still won’t work.
We did find out from Omron that the NX-EIC202 board we area testing right now is of version 1.0. And there is also a newer 1.2 version of the device where there some improvements in "communication with 3rd party masters". We should get the new v.1.2 this week so the testing continues then…
 :help:
Thanks
Ricki


Offline zicki_88

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 13
Re: Configuring Omron NX-EIC202 to work with irb 1200
« Reply #1 on: August 03, 2017, 07:05:31 AM »


Got it working with the 1.2 versio.

 :dance2:

Offline neoex17

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 4
Re: Configuring Omron NX-EIC202 to work with irb 1200
« Reply #2 on: March 20, 2018, 07:11:40 AM »
Hi,

I am trying to connect the omron nx-eic202 to abb yumi robot and the ethenetip_device parameters in EIO are as follow:

      -Name "NX_EIC202_Input_Output" -VendorName "OMRON Corporation"\
      -ProductName "NX-EIC202" -Label "NX-EIC202 - Input / Output"\
      -Address "192.168.125.88" -VendorId 47 -ProductCode 1660 -DeviceType 12\
      -OutputAssembly 148 -InputAssembly 100 -ConfigurationAssembly 199\
      -ConnectionPriority "SCHEDULE" -OutputSize 2 -InputSize 4

but I still getting error:

60           E          IO & Communication     71534      Invalid output size for EtherNet/IP adapter   2018-03-20 11:13:27    The adapter NX_EIC202 has an invalid output size. Maximum output size supported is -2 bytes.

69           E          IO & Communication     71572      I/O device has entered error state         2018-03-20 11:14:13    System has indicated that the I/O device NX_EIC202 with address 192.168.125.88 on the network

Is it possible for you to share your settings with me?

Thanks in advance.

Offline zicki_88

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 13
Re: Configuring Omron NX-EIC202 to work with irb 1200
« Reply #3 on: March 20, 2018, 07:46:15 AM »
Hi

      -Name "NX_EIC202" -VendorName "OMRON Corporation" -ProductName "NX-EIC202"\
      -Label "NX-EIC202 - Input / Output" -Address "192.168.125.110"\
      -VendorId 47 -ProductCode 1660 -DeviceType 12 -OutputAssembly 148\
      -InputAssembly 100 -ConfigurationAssembly 199\
      -InputConnectionType "POINT2POINT" -ConnectionPriority "SCHEDULE"\
      -OutputSize 14 -InputSize 36

Of what versio are your NX_EIC202 adapter?
Older than v1.2 will not work.

-Ricki

Offline neoex17

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 4
Re: Configuring Omron NX-EIC202 to work with irb 1200
« Reply #4 on: March 20, 2018, 09:23:31 AM »
Hi,

Thank you very much for the fast reply.
I checked the coupler version in sysmac studio showing version number 1.0, so we will return our loan unit to omron for version update.
Will update again after getting new loan unit from them.

Offline neoex17

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 4
Re: Configuring Omron NX-EIC202 to work with irb 1200
« Reply #5 on: April 10, 2018, 09:58:23 AM »
update:
we managed to communicate with the Omron NX-EIC202 using version 1.2 coupler.